Минаване от 5.6 на 7.2

Използвам Wordpress и искам да мина от php 5.6 на 7.2, но като тествах плъгините с една програма
PHP Compatibility Checker преди да мина на 7.2 за 2 плъгина ми изкара error с червено и за 3 плъгина и за темата ми изкара оранжево. Грешките за error са за плъгините, които са ми нужни в сайта.
Google Captcha (reCAPTCHA) by BestWebSoft
WPeMatico

Грешките за тях са тези, има ли начин да се оправят и ако оставя така и мина на 7.2 ще правят ли мизерии като забавяне на сайта и т.н. ?

FILE: /home/simmods/public_html/wp-content/plugins/google-captcha/lib/recaptchalib.php
-------------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 4 ERRORS AFFECTING 3 LINES
-------------------------------------------------------------------------------------------------------------------------------------------------------
200 | ERROR | The constant "MCRYPT_MODE_CBC" is deprecated since PHP 7.1 and removed since PHP 7.2
201 | ERROR | The constant "MCRYPT_RIJNDAEL_128" is deprecated since PHP 7.1 and removed since PHP 7.2
203 | ERROR | Function mcrypt_encrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
203 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
-------------------------------------------------------------------------------------------------------------------------------------------------------

И за другия плъгин

FILE: /home/simmods/public_html/wp-content/plugins/wpematico/app/lib/SimplePie/Item.php
---------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
---------------------------------------------------------------------------------------
124 | WARNING | INI directive 'zend.ze1_compatibility_mode' is removed since PHP 5.3
---------------------------------------------------------------------------------------


FILE: /home/simmods/public_html/wp-content/plugins/wpematico/app/lib/SimplePie/File.php
-------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
-------------------------------------------------------------------------------------------------
112 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
-------------------------------------------------------------------------------------------------


FILE: /home/simmods/public_html/wp-content/plugins/wpematico/app/lib/SimplePie.php
--------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------------
709 | WARNING | INI directive 'zend.ze1_compatibility_mode' is removed since PHP 5.3
--------------------------------------------------------------------------------------


FILE: /home/simmods/public_html/wp-content/plugins/wpematico/app/wpematico_functions.php
--------------------------------------------------------------------------------------------------
FOUND 3 ERRORS AND 1 WARNING AFFECTING 4 LINES
--------------------------------------------------------------------------------------------------
1420 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
1421 | ERROR | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
1422 | ERROR | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
1433 | ERROR | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
--------------------------------------------------------------------------------------------------


FILE: /home/simmods/public_html/wp-content/plugins/wpematico/app/debug_page.php
-------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
-------------------------------------------------------------------------------------------------
502 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
-------------------------------------------------------------------------------------------------


FILE: /home/simmods/public_html/wp-content/plugins/wpematico/app/campaign_fetch.php
------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 1 LINE
------------------------------------------------------------------------------------------------
78 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
78 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
78 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
------------------------------------------------------------------------------------------------
 

Green Bars

Well-Known Member
Ами ще почакаш явно да направят версии за плъгините съвместими със 7.2 , аз за това минах на 7.1 защото не всичко е готово за 7.2
 
Ами ще почакаш явно да направят версии за плъгините съвместими със 7.2 , аз за това минах на 7.1 защото не всичко е готово за 7.2
Ми това пречи ли, ако така с error мина на 7.2 тъй като не виждам никакъв проблем от страна на плъгин като минах за малко всичко си работеше и предупредителните за другите проблем ли са, защото те светят в жълто ?
 

cross

Well-Known Member
Ми това пречи ли, ако така с error мина на 7.2 тъй като не виждам никакъв проблем от страна на плъгин като минах за малко всичко си работеше и предупредителните за другите проблем ли са, защото те светят в жълто ?
На 7/7.1 ще си ок :)
 

Горе