Проблем с loop-single.php и плъгин за testimonials

ivo1017

Active Member
Ползвам на един сайт темата twenty ten и custom child theme. Проблема е, че като сложа плъгин за testimonials, в случай Testimonials Widget ми връща грешка:
Call to undefined function twentyten_posted_on пък до папката с темата/loop-single.php on line 29

Пробвах и с други плъгини за testimonials и пак дава същата грешка. Възможно ли е проблема да е в темата и какво да търся, за да го оправя.
 

r.stefanov

New Member
От: Проблем с loop-single.php и плъгин за testimonials

Прегледай си логовете за php, там пише къде е проблема. Ако са забранени в php.ini от доставчика ги питай как да си ги пуснеш. Съмнявам се да нямат опция в cPanel-a де.

Или разреши error report-а от Wordpress: http://codex.wordpress.org/Editing_wp-config.php#Configure_Error_Logging
 

TheCrazyBastard

Well-Known Member
От: Проблем с loop-single.php и плъгин за testimonials

Отваряш с текстов редактор, който отброява редовете отстрани, като notepad+ примерно файлът, който ти дава грешката.. В случая отваряш темата/loop-single.php и копираш функцията или всичко, което е изписано там на ред 29. Пускаш го този ред в търсачката на Гугъл и търсиш решение на проблема ти, ако някой друг го е споделил в мрежата. Пусни го този ред и тук, да го видим. Понякога оправяш ред, появява се друга грешка.. и така може да оправиш 10 грешки, докато заработи, а понякога може да премахнеш само един празен ред и живота ти да стане по-лек :)
 

ivo1017

Active Member
От: Проблем с loop-single.php и плъгин за testimonials

Ред 29 в този файл е:
<?php twentyten_posted_on(); ?>

Ще погледна и на хостинга за логовете от php.
 

TheCrazyBastard

Well-Known Member
От: Проблем с loop-single.php и плъгин за testimonials

Пробвай с това, но преди това си свали оригиналните файлове, за да може да ги върнеш, ако нещо се оплеска:

Edit the loop.php, loop-single.php files and delete the following code blocks:

<div class="entry-meta">
<?php twentyten_posted_on(); ?>
</div><!-- .entry-meta -->
 

ivo1017

Active Member
От: Проблем с loop-single.php и плъгин за testimonials

Тествам на локална инсталация. Изтрих го и се оправи, но се появи в ред 53:
<?php twentyten_posted_on(); ?>
. Изтрих и него и за сега няма проблем. Благодаря за помощта. Надявам се да не пиша отново в темата.
 

Горе