What is wrong with OpenCart version 1.5.6?

Blinky

Owner
I am writing in this section, because I want this to be visible for most of the webmasters around the world and also we do not have so many topics about shopping carts here. Whatever, today I tried to update on store based on OpenCart? So fas, so good. But no, the update failed up. Why? I do not know. And as fas as I am reading in forums and sites, I am not the only one with this problem. So, I would love to ask, if there is someone familiar with the problem...What the hell is wrong with the latest OpenCart update? :shock:

Is there something undone by the programmers? Or maybe the shopping cart has a problem, like never before?

What I have done? I stopped with the update and got back the old version. Will keep stay with it till there is some solution. Opening this thread just to ask am I the only one with this problem? Does anyone have the same one? And is there any permanent solution or should we wait till the bugs are fixed? Thanks a lot your time. Your help will help me a lot. I have decided, but anyway, I can make it with the old version.
 

Blinky

Owner
What is wrong with OpenCart version 1.5.6? Problems with OpenCart version 1.5.6

try to export product do a clean install and import them :)
Defiantly, this will happen. :) There are two possible things that could be done - leave it the way it is on version 1.5.x and keep running your site or make a new install and hope the import/expert module works the way you want it. :) In the first option some of the stuff will stop working and sooner or later we should get this 1.5.6 version for OpenCart. Will think of it a little bit more and will take some decision. But I am into the second option. :)

I did the new installation and it works fine, but when you try to do it for an existing store, guess what....starts some mysql errors, that will take you a lot more time to fix it.

Here how should it looks like:



There is anther great think you should now miss:

Warning: Install folder still exists and should be deleted for security reasons!
 

Brum

New Member
As I see they started to fix all the bugs there. Soon will be great and everyone will need to get it. I noticed some really interesting changes around here with the new open cart version 1.5.6 - the text editor is cooler than ever, even cooler than the WordPress. :)

Also, be careful whey you so the export / import from the old to the new version. ;)
 

Blinky

Owner
For now, the latest version is having some bugs, but with the time, hope to remove them all. The fact is that Open Cart, Zen Cart, WP eCommerce and Magento are one of the most popular shopping carts - Which Shopping Cart Do You Use?

Still scared to use WP eCommerce, but will try it in the next months. They reached version 3.7.1 :) Well, has better update process than other platforms. :)
 

$INeed$

Well-Known Member
The worst thing about this is that theme authors are still making open cart themes, that are suitable with the oldest version, like 1.5.5, 1.5.4 and 1.5.3. Newest themes with responsive designs, attractive widgets, dinamic elements and etc. are not suitable with versions oldest than 1.5.1 as I can see on some sites selling premium themes for CMSs.

Here is an copy->paste example:

Features

Compatible with Opencart 1.5.5, Opencart 1.5.6
Support Wide Screen 1170px, 980px
Built-in Pavo Framework Version 2.0 and Bootstrap 3.0
No Hacking Core Opencart Codes

For themes that are new and modern at the same time. The old ones are OK for oldest open cat versions. ;)
 

Brum

New Member
Yes, in themeforest.net, I see it often. Unlike the old versions, the new updates in the new versions are OK as long as they not giving any bugs. In most theme pages you can see "Support Opencart 1.5.6, 1.5.5, 1.5.4".
 

Горе